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Overview 

SalusSTS is an analysis workflow designed for Salus high-resolution spatial transcriptomics capture 
chips. It enables users to analyze whole transcriptomes in both fresh frozen and paraffin-embedded 
tissue sections. SalusSTS includes quality control, alignment to match reads, generation of expression 
matrices, automatic segmentation of tissue regions, clustering, and other extended analyses. 

 

1. Getting Started 

 

1.1 System Requirements 

SalusSTS runs on Linux systems with the following minimum requirements: 

• 8-core processor (32 cores recommended) 
• 128GB RAM (256GB recommended) 
• 1TB storage space 
• 64-bit CentOS/RedHat 7.8 or Ubuntu 20.04 and above 

To run the workflow on a server cluster, the following conditions must be met: 

• Shared file system (e.g., NFS) 
• Slurm workload management system 

 
1.2 Software Dependencies 

Singularity 

 

1.3 Download and Install 

Step 1: Install Go and Singularity 

 

 



 

 

Singularity v3 and above are primarily developed using the Go programming language, so you need to 
install Go to compile the source code. It is recommended to use Go v1.20.4 (https://go.dev/dl/) and 
Singularity v3.10.4 (https://github.com/sylabs/singularity). 

 

 

Step 2: Download the SalusSTS image 

Domestic storage path: The file shared via cloud drive: salusts.v1.0.sif 

Link: https://pan.baidu.com/s/14SBKmZEF07Dz21XdLq-3jg Extraction code: nxhw 

International storage path: 

You can download and place the image file anywhere that is convenient. 

 

 

2 Inputs 

 

2.1 Build References Index 
 
The Salus analysis workflow is compatible with 10X Genomics pre-built reference genomes. For users 
building a custom reference genome index, please refer to the STAR software tutorial. You will need to 
download the reference genome files for your species (fasta, gtf). Assuming the file tree is as follows: 

 
Before running Singularity, you need to map the internal and external paths of the image. According to 
the file tree, /share is the common parent directory, so use the Singularity -B parameter to map /share. 
The command is as follows 

 

https://go.dev/dl/
https://github.com/sylabs/singularity
https://pan.baidu.com/s/14SBKmZEF07Dz21XdLq-3jg


 

2.2 Slide types  

SalusSTS currently supports two chip types: dual-row chips, which have a total of 10 valid wells, with 
each well measuring 8.6mm x 8.6mm; and single-row chips, which have 4 valid wells, with each well 
measuring 11mm x 11mm. 

 

The Salus spatial transcriptomics chip features a notch in the upper right corner. For dual-row chips, the 
wells are named from bottom to top and left to right in the following order: A2, A1; B2, B1; C2, C1; D2, D1; 
E2, E1. Each experiment uses one well, and the Salus analysis workflow will crop and analyze data based 
on the specified well. 

In the fstBC sequencing files, lane01 corresponds to all probe information for chip positions A1~E1, 
while lane02 corresponds to all probe information for chip positions A2~E2. For single-row chips, the 
wells are named from bottom to top in the order: A, B, C, D. In the fstBC sequencing files, lane01 
contains all probe information for chip positions A~D. 

Please note that in the config.yml file, single-row and dual-row chips correspond to different ChipType 
values. 

2.3 Inputs for SalusSTS 
 



To run the SalusSTS workflow, you must import three sets of fastq files: the fstBC file that records probe 
position information, and the user's sample library files R1 and R2. There are usually multiple pairs of R1 
and R2 files. 

fstBC: [Lane No.]_[Date]_[Machine No.]_BC.fastq.gz 

For dual-row chips, Lane01 records the probe position information of the upper row, and Lane02 records 
the probe position information of the lower row; for single-row chips, the fstBC file only has files starting 
with Lane01. 

R1: Records barcode and UMI sequence information in the user's sequencing data. The length is 40 nt, 
with the first 30 nt as the barcode and the last 10 nt as the UMI. Different sequencer settings may result 
in R1 files of varying lengths. If R1 contains a fixed intermediate sequence, config.yaml should be run in 
"cut" mode to trim it. If the barcode and UMI together form a 40-base sequence file, config.yaml should 
be run in "dark" mode. 

R2: Records RNA insert fragment information from the user's sequencing data. 

R1 and R2 file names must start with a letter, number, or underscore. File names can include letters, 
numbers, underscores, dots, hyphens, or spaces, but they must contain .R1 or .R2, _R1 or _R2 to identify 
read 1 or read 2. The extension can be any of fq.gz, fastq.gz, fq.gzip, or fastq.gzip. It is not required for file 
names to contain "Lane," nor is it necessary for files to be stored in subfolders corresponding to Lane*. 
Note that sometimes sequencing data obtained by users has already been pre-processed. R1 and R2 
files have had adapters removed and quality filtering completed. fstBC files have undergone quality 
filtering and been converted to a new coordinate system. The workflow supports input of pre-processed 
sequencing data, and corresponding file naming and config.yaml settings will vary. Specific changes are 
recorded in the "Run with clean reads" section. 

H&E stained images (optional): In spatial transcriptomics, H&E stained images can be combined with 
gene expression data to assist with tissue cutting, cell segmentation, and other tasks. 

2.4 Configuration file Settings 
Each time you run the Salus spatial transcriptomics SalusSTS analysis workflow, you need to create a 
new working directory, copy the config folder into this working directory, and make the necessary 
modifications. The config.yaml file is used to configure the program's parameters, while the fqlist.csv file 
records information about the input fastq files. Below is a demonstration of how to set up the 
configuration files for running a single sample or multiple samples on the same chip. 

 



The completion of the config.yaml file is not affected by whether you are running a single sample or 
multiple samples. Below is an example of how to configure the config.yaml file. Please note: 

1. When you first copy and paste the contents of config.yaml, you need to replace the separator before 
the "#" symbol with a space; 2. When entering each parameter, be sure to leave a space between the 
value and the ":" symbol. 

 



Suppose the sequencing file storage path is as follows: 

 

 
 
Suppose the sequencing file storage path is as above: 

Run1, run2, and run3 represent multiple sequencing runs of the same library. Below is an example of 
how to fill out the fqlist.csv file: 

 

Run one sample 
 



The following is the specification for filling out fqlist.csv. Please note that fqlist.csv must not contain 
extra blank lines, or an error will occur. 
 

Parameters 
 

Description 
 

seqType 
 

Used to indicate whether the input fastq sequence file of a chip 
(fst) or a user experimental sequencing file (snd); must be in 
lowercase. 

fqPath 
 

The sequencing files must be stored in the specified path and must 
have filenames ending with fastq.gz or fq.gz. By default, the snd 
row input path should contain both the R1 and R2 sequencing files. 
 

chipZone 
 

Record the well position used in the experiment; this will be used 
for cropping in subsequent analyses. Note that in fstBC 
sequencing files, this field does not need to be entered, and it 
must be in uppercase. 
 

sndBarcodePrimer 
 

Records the sequencing mode of the user's library after library 
preparation, either "pe" (paired-end) or "se" (single-end). This field 
does not need to be filled in for rows containing fstBC sequencing 
files and must be in lowercase 
 

sampleID 
 

The chip code corresponding to the fstBC row, and the user-
defined sample name for the sndBC and sndNA rows. Please note 
that special characters such as "_" should be avoided in the 
sampleID name, as they will be treated as separators and may 
cause errors. 
 

Run multiple samples 

 
The program does not support running files from different chips in the same working directory; only fstBC 
files from the same chip are allowed as input. 



Run with clean reads 
If the sequencing data you obtained has already had adapters removed and quality filtering completed, 
you need to set the cleanedRead and cutedRead parameters to True in the config.yaml file. Importing 
fstBC files that have not undergone quality filtering and coordinate system conversion in this workflow 
will result in abnormal outputs. All three input files must follow the new naming conventions: 

• fstBC: /path1/[LaneNo.]/newCoord_fstBC_[sampleID]_[ChipType]_BC.fq.gz 
• R1: /path2/[sampleID]_[chipZone]_R1.fq.gz 
• R2: /path2/[sampleID]_[chipZone]_R2.fq.gz 
• R1: /path3/[sampleID]_[chipZone]_R1.fq.gz 
• R2: /path3/[sampleID]_[chipZone]_R2.fq.gz 

Each pair of sndBC and sndNA files must be located within the same folder, and only one pair of fastq 
files is allowed per subfolder. There can be multiple folders under the directory, corresponding to 
different lanes. Note that each pair of fastq files is distinguished by the R1 and R2 suffixes, and their 
prefixes should be consistent and defined by the user. The fqlist.csv configuration setup can remain 
unchanged. 

If the user receives high-quality sequencing data that has not had adapters removed, set cleanedRead 
to True and cuttedRead to False, and the file naming rules remain the same. 

3.Running Pipelines 
 

Quick Start 
The SalusSTS workflow has been packaged as an image, and users can easily start the workflow by 
following these steps: 

Step 1. Enter the working directory for this analysis task, for example: /share/home/salus/demo/workDir. 

Step 2. Make sure the configuration files in the config folder have been properly set up, and confirm that 
the singularity command can be run successfully. 

Step 3. Before officially running the workflow, perform a dry run to check the integrity of the process. 



 

 
Step 4. Run the workflow. 

If running on a single server, you can execute the following command: 

Running in the cluster 
 

If you are submitting tasks on a cluster where the job management system is Slurm, you can use the 
sbatch command to submit job-name.sh and use the squeue command to check all tasks. Task 
submission can be performed on the login node mn01. Enter the working directory for this analysis task 
and save the following code in the job-name.sh text file. 

 



Resubmit a failed process 
 
 SalusSTS supports breakpoint resumption. If the workflow is interrupted for any reason, incomplete 
intermediate files from the current step will be deleted. 
Before re-executing the workflow command, you need to run the snakemake --unlock command to 
unlock file protection. After submitting the task again, the workflow will continue from the last completed 
step. 

Manual Alignment HE 

Step 1. Generate preprocessed images for manual alignment in ImageJ 

When the HEtifPath in the config.yaml file points to the location where the original HE images are stored 
and TissueSegmentHE is set to True, the workflow will automatically read the color HE images and scale 
them to grayscale images with the same resolution as the binned chip gene expression images. Users 
can also generate these images manually: 

 

 



 

Parameters Description 
-p  Specifies the path to the bin-segmented sparse matrix 

file, which must be consistent with the -b parameter. 
-i  HE image at original resolution 
-o Output file directory; the current resolution will be 

used as the standard reference for contours 
-b Specifies the bin resolution used for segmentation 
-f Specifies the scaling factor for the HE image; a value 

less than 1 will reduce the image size. 
The screen will display the recommended image contour segmentation threshold value from the OTSU 
algorithm, such as "Recommended threshold_value:109." 

This threshold is used in HE_mask.py to binarize the registered H&E grayscale image, and users can 
modify the threshold value if needed. The workflow will generate mask1-5 to show the results using 
different denoising and contour closure parameters, making it easier to select the appropriate 
parameters. 

 

 

 



 

Step 2.1. Manual registration in ImageJ (choose any method) 
 

Recommended online tutorial (https://www.ai2news.com/blog/3089995/) 

Fiji ImageJ → Plugins → BigDataViewer → BigWarp 

ImageJ download link (https://imagej.net/software/fiji/downloads) 

Select the H&E image as the moving image and the sequencing result heatmap as the target image. The 
goal is to ensure the resolution of the registered image matches that of the sequencing result heatmap. 

If the sequencing result heatmap appears dim, you can adjust its brightness using the toolbar: Image → 
Adjust → Brightness/Contrast. 

Press the spacebar to toggle marking mode on/off. Use the right mouse button to move the image and 
the left mouse button to add landmark points. You must select four landmark registration points and 
export the landmarks.csv file and warped image from the registration page on the right side of the 
following image. 

Note that the resolution of the registered image should be consistent with GeExmap.tif. After the warped 
image is generated in the viewer, you need to click on the image and then save it from the main ImageJ 
toolbar. 

 

(Registered image) 

 

 

https://www.ai2news.com/blog/3089995/
https://imagej.net/software/fiji/downloads


 

Step 2.2. Overlaying Layers in Photoshop 

Step 2.2.1: Open and Convert to Grayscale 

1. Launch Photoshop and open your image by using File > Open to select the color image you want to 
convert to grayscale. 

2. Convert to grayscale: Choose Image > Adjustments > Desaturate, or use the shortcut Shift + Ctrl + U 
(Windows) or Shift + Cmd + U (Mac). Alternatively, select Image > Mode > Grayscale and click Discard 
to remove the color information. 

3. Add an adjustment layer: At the bottom of the Layers panel, click the Create new fill or adjustment 
layer icon and choose Black & White. 

4. Adjust parameters: In the Properties panel, you can adjust the sliders for each color channel to 
achieve the best grayscale effect. 

 



 

Step 2.2.2: Invert Black and White Colors 

1. Select the layer: In the Layers panel, make sure the layer you have already converted to grayscale is 
selected. 

2. Invert the colors: Choose Image > Adjustments > Invert, or use the shortcut Ctrl + I (Windows) or 
Cmd + I (Mac). 

Step 3: Save the inverted grayscale image 

Save the image: Use File > Save As... or File > Export > Export As... to choose the save location and file 
name (for example, inverted_gray_image.tif). Upload the registered HE images for each sample to the 
folder /results/ManualHEmask/pre_{sampleID}_{chipZone} generated by the workflow. 

By following these steps, you can convert a color image to grayscale in Photoshop, invert the black and 
white colors, and save the final result. 

Step 3. Test contour parameters 

This step allows users to experiment with different parameters for HE image contour segmentation. 
Based on the mask1-5 files generated in Step 1, users can select the desired segmentation parameters 
and generate the mask.tif file for subsequent standardization of contours across different resolutions. 
The -t parameter specifies the threshold for image binarization, and -m determines the methods for 
handling contour noise, holes, and edges. The mask.tif file generated in this step will be used to 
standardize contour shapes at various resolutions. Please note that, in the registered reg.tif image, the 
tissue region appears as bright white, while the background is black. 

 

Parameters Description 
-p Specifies the path to the bin-segmented sparse matrix 

file, which must be consistent with the -b parameter. 
-i HE image uploaded by the user after registration 



-o Output file directory; the current resolution will be 
used as the standard reference for contours 

 

 

-b Specifies the bin resolution used for segmentation 
-t The threshold value for image binarization 

segmentation; it is recommended to use the threshold 
suggested in Step 1. 

-m Preprocess image contours using different parameter 
sets, including combinations of dilation and erosion. 

 

Step 4. Use the same contour at different resolutions 
When the mask.tif file is generated under the /results/ManualHEmask/pre_{sampleID}_{chipZone} folder 
and the ReadManualHEmask parameter in the config.yaml file is set to True, rerunning the workflow will 
produce tissue segmentation results and corresponding reports at different resolutions. 



Please note: If there are multiple samples in a results folder, you must prepare mask.tif results for each 
sample to ensure that subsequent steps run correctly; otherwise, errors may occur. 

 

 

Manually select ROI 
Step 1. After importing the registered H&E image into ImageJ, select the region of interest (ROI). In the 
toolbar, click "Analyze" > "Tools" > "Save XY coordinates" to save your selection as the manualroi.csv file. 
Make sure the resolution of the imported registered image matches the bin size of the sequencing data. 

Step 2. Create a new ROI folder under /workDir on the server, and upload the manualroi.csv file to this 
folder. 

Step 3. Run the barcin.py script, which will output a file containing the original barcode sequences and 
coordinates corresponding to the binned barcodes. 

 

 

4. Outputs  
Overview 

 
Each successfully completed workflow will generate the following file tree. If the workflow is interrupted, 
you can check run.log to identify the step and reason for the interruption. 

 

 

 



 

 

 

 

 

 



Results 

The detailed results file tree is as follows: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

 

 

 



 

 

 



 



 

 

 

Logs 

 



 

 


